BB Child Theme - Anchors not resolving on internal page.

I have been through the info on the KB and Forum to resolve this issue I am having, but have finally broken down to be needy and shout for some direction.

Usually in WordPress one sets the appropriate link URL link and ‘#section-name’ from the originating element, plus the final destination anchor ''on a destination page element.

In BB its done a bit differently.

I have a Callout Call To Action link on the Front Page set to link to a content point on an internal page. Though the link goes to correct page, it does not land at the targeted section, but at the top of the page.


Callout Link:

Destination element ID set on a row:

Is there something I am missing with setting up the unique ID structure?


Hey John,

This article is a bit buried in there, but definitely what I think you are after here. Have a look and let me know if that helps!


Billy, yes, that’s the article I found and followed. That’s what is not working for me.

Per the article:

  1. Added A Unique ID To The Destination Element’ for custom ID, which is a row.
  2. Added The Unique ID To The Link’ for Button Link

Hey John,

Just wanted to chime in. Do you mind sharing a screenshot so we can take a look? You can upload it to imgur and paste the link here. Or if you can share the URL of the site we’ll be glad to take a look.



I have attached the screenshots for the for the Front Page Callout and the Internal Page destination row section.


Hey John,

Thanks for the screenshots, it really helped alot. I would like to refer to the second screenshot . In your Callout Settings > Call To Action > Link , just insert “#wordpress-page-design-row” for the link (Attached screenshot). Let me know if it works.



KC thanks for taking a look (sorry, I got off-track for a day).

Yes, I have tried inserting the ‘#wordpress-page-design-row’ in the Callout as opposed to the full URL and ID. Tried it again, just to recheck, the link does not work as. There is no link created to reach the destination page.

I checked for any conflicting plugins for conflicts, but nothing there.

I don’t know, I believe, I am not doing a stupid ‘wood for trees thing’.

I may have to revisit this issue once I upload the site to a server.

Hey John,

That’s really weird. Do you mind sharing temp admin access so we can take a look?