Beaver Builder no longer shows a cursor for editing, nor saves work done on a Web page

Out of the blue, my simple, single page Web site shows the Beaver Builder interface when I open to edit in Beaver Builder, but the cursor won’t highlight text boxes or images. I was able to get them to show by dragging over a “Text Editor” icon, but any changes made are unable to be saved and published. I tried all the solutions I found in the forum (deactivate all plugins, eliminate shortcode, etc.) but nothing helps. I have had others look at it to no avail. I’m at my wit’s end and don’t know what to do next. Any help would be greatly appreciated.

You should really contact support.

Can I get support if it’s the free version?

Not really, if you want free support you are going to have to provide more info, like the url for the site.

Ok, the URL is Is there other information I should provide?

Ah yes, if you look in the browser console, you will see a JS fatal error, tis error is preventing the builder from loading… in fact it will break anything powered by JS on the page. So the error is coming from the BB layout JS file which means somebody added something to either the layout JS or global JS setting in BB

You can see the text here: Image 9-20-2022 at 7.31 PM

You can probably use safemode to get into the builder and remove the text from the JS settings

I was able to go to the Web page in safe mode, but I’m not sure how to get into the BB settings in safe mode. I tried this - " 1. Check each module, looking especially for any custom HTML or JavaScript. Custom HTML can be inserted into any field that accepts text. JavaScript is more likely to have been placed in an HTML or Text Editor module." and couldn’t find any to get rid of." I see what you are saying, but not sure how to get in there to fix it.

The text you added is not part of ANY module, its the layout JS or global JS

Where do I find the layout JS or global JS? I clicked on the title in the upper left hand corner for tools and found a snippet of CSS code, but the Javascript tab for both “Layout CSS and Javascript” and “Global Settings” is grayed out.

If you enable debug mode you can edit the global JS/CSS in the wp-admin area

Thank you! I think that fixed it! Will test some more.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.