builder no longer loads after saving A page with embedded video

Hi I got help about embedded videos
http://forum.wpbeaverbuilder.com/support/q/how-to-embed-a-youtube-video-with-modest-branding/

Thanks for that. Unfortunately it hasn’t solved my other issue and my client just had it too.

After using the YouTube embed code I click update or publish. Everything looks fine, but from that point on its no longer possible to edit the page with page builder. Instead of loading the builder it loads the front facing page (what the public sees).

I’m at a complete loss as to a resolution… :confused:

This is now even worse. If I create a new page, and click on the builder the url goes to mysite.com/?page_id=62&fl_builder

and I get the following error:

Sorry! That page doesn’t seem to exist.

I could really use some urgent help on this. I only bought the plugin 3 days ago - its not working properly at all.

I’ve gone to settings/ builder/pageuninstall

then re-installed.

No change at all. It’s still broken.

OK i’ve narrowed down the issue to the wordpress domain mapping plugin.
Yesterday, my client built the site in pagebuilder, then I made it live by mapping the domain in the plugin and setting it to primary.

Obviously I can’t operate my clients site this way - it’s live and the address bar needs to have the clients domain in it.
What is the solution?

OK I have managed to resolve this. I had to log out of my multisite, and then log in at the mapped domain i.e. clientsite.com/wp-admin

in the domain mapper I also unchecked:

  1. Remote login
  2. Redirect administration pages to site’s original domain (remote login disabled if this redirect is disabled)

the builder didn’t detect that I wasn’t logged in and freaked out - but instead of asking me to log in, it gave me a page doesn’t exist error.

I can see some other people here have had domain mapping issues. If you add some user logged in checking code to your page builder when it loads, you might fix this problem for a few people. :_)

ok now the builder is working but the images and fonts are missing from the builder - and only on the domain mapped site. Arrrg!

row edit box example

turning off the primary domain option again in the domain mapping plugin restores the images. It’s clearly a bug.

When primary domain is enabled. If i open the source code in the builder, the links are pointing to both the none primary and primary domain. Both links are working, but maybe this is where the bug is. The page builder seems to be getting confused about the site url???

Hey Tim,

Do you think you can share temp admin access as well as FTP access to your site so I can have another member of the team take a look?

Ben

sure. i don’t want to post it here though. can you give me a way to pass on the details?

Hey Tim,

Go ahead and send it over to themes [at] fastlinemedia [dot] com.

Ben

Hey Tim,

Sorry for the hassle. It looks like this might be an Nginx config issue that’s causing the ?fl_builder variable to not be recognized in the URL. Here’s a link to a solution for that. Can you give that a shot?

http://forum.wpbeaverbuilder.com/support/q/templates-pop-up-not-showing-on-clean-install-with-bb-plugin-and-theme/page/2/#post-18428

Let me know how it goes.

Justin

OK i’ve implemented the change and restarted nginx, but there is no change - The images are still missing. Apparently the fonts are missing too.

[Content Hidden]

Thanks for the follow up and additional info. The issue makes sense now. Part of the problem is that I have the font icons installed on my computer, so I’m still seeing them even though they’re not loading on your site.

The reason they are not loading is because you can’t load fonts cross-domain. The URL you are visiting is ben-green.co.uk while the fonts are being loaded over bengreencouk.jamhost.it.

While the BB plugin is loading the fonts, we are using a core WordPress function to build the URL. Specifically, we’re using the plugins_url function which is a fairly standard way to build the URL.

I know that others have had domain mapping issues before, but they’ve typically revolved around login issues, not cross-domain font issues like this. So, I’m not yet sure what the solution is. It very well could be a domain mapping setup issue, but let me do a little more digging and get back to you.

Justin

Hey Tim,

I have a solution I would like to test, but I’m not able to edit files via FTP. Can you check that out for me?

Thanks!
Justin

Hey Tim,

Unfortunately, that didn’t work. I’m still seeing this message…

“Couldn’t get remote handle. Make sure you have permission to modify this file.”

Sorry for the hassle!

Justin

I have configured standard ftp on port 21 now. Please let me know when you are done because its very, very insecure.

Thanks, Tim! Diving in now.

Justin

Hey Tim,

Can you try it now? You should be all set.

I still think there is an issue with your domain mapping setup somewhere. I checked a few other customers’ multisite setups and the plugins_url function is return the correct URL. Not sure what it could be, but I was able to implement a workaround for this edge case.

Let me know if you run into any other issues.

Justin

Hi. This issue is fixed now. Are you able to tell me what you did - I expect to be adding more sites in the future, and if I can resolve the issue myself then I would like to do that…

Thank you.