Builder not working

Hi there,
I have created a theme and I have problems getting beaver to run on my page.
It loads well and I get all the elements on the right side. But they are all inactive and if I hover over my content, the editing tools don’t appear.

Jquery seems to be integrated ok and I have wp_head and wp_footer codes implemented.

The menu is supposed to be fixed at the bottom but after finding a post here in the forum saying the a div with a fixed position can be a problem, I removed the “fixed” attribute. But still no luck.

I will happily provide you with login details so you can have a look.
Thank you!

[Content Hidden]

Hi Anja,

Sorry to hear about the issues! Let’s have you try a few things if you don’t mind to see if we can determine where the issue lies.

  • Disable all plugins and test the Beaver Builder while reactivating each to determine if the issue is related to a 3rd party plugin.
  • Provide browser versions being used and error logs, if possible.

Let me know when you have a chance on the above and we’ll go from there!


Hi Billy,
thanks for your help. I have tried those things already. Beaver Builder works with all plugins enabled but another theme (twentytwelve) . Feel free to switch themes to try that out.
So I’m quite sure it’s something with my theme. Maybe I missed something when I made the theme.

I could invite you to my bitbucket rep where you could look at the theme-code or I could give you a dropbox link to my theme so you can look at it if you need to. Just let me know what you need.

And if YOU want to test things in wordpress admin (like deactivating plugins or switching themes), go ahead. The site is not live!

Thank you so much! I really hope we can fix this together!
Best wishes

Using current versions of Firefox, Chrome and IE (error occurs in all of them).

Hi Anja,

Thanks for getting back. We’ve issued a bug for this issue and we’ll let you know as soon as we have a solution!


Hi Anja,

It appears that you’re not using “the loop” in your custom theme. Not using the loop works in most cases, but can cause unexpected behavior. It is always recommended to use the loop when outputting post content. I have updated your page.php template with the loop so you can see how it’s done.

The builder is now working although it looks like you need to do some CSS work to make it full width as the content area is really small.


Thank you so much guys!
That helps me a lot and I will use the loop!
Everything’s fine now and I’m even happier with the beaver than I was before, now that I know there’s also great support behind it!
Good job and great product!

Thanks Anja, glad we could help!