Doesn't work on subsites

I’ve always been able to have Beaver builder Agency work on my main multisite fine, but any subsites when editing, it just shows a nearly frozen screen as no buttons work what-so-ever, and it just shows the right side panel of row layouts, basic modules, etc- and nothing expands or works.

Everything does work fine on the main multisite no problems, so I’m not entirely convinced that it is another plugin causing breakage. I reinstalled the plugin, updated to the latest, and used an older version (1.4x) and it’s still not working for a subsite.

Some notes: I use Varnish, but I do not cache urls with “fl_builder” or “post_id” in them or anything in the backend for that matter. The backend is also SSL encrypted, but once again, all this does not stop BeavBuilder from working fine on the main multisite…

I’m looking for solutions to this issue… Thanks!

Maybe this helps, but in the browser console of a logged in subsite on the page builder page, 2 errors that says it refuses to load is “http ://” and “http ://”. (ignore the space in between the http and : as this message board keeps autoformatting it to https) However, on the main multisite on a builder page, it shows them correctly as https when looking through the source, no errors like that in the console, and it works…

These are the only differences I see as noteworthy when looking at the multisite and subsite builder browser console.

Hey Carmelo,

Would it be possible to get temporary admin access to test this?


[Content Hidden]

Thanks, Carmelo. It looks like the issue is that the Facebook script isn’t loading because it’s being blocked since it’s not HTTPS. Since that’s not loading, subsequent calls to the FB variable that doesn’t exist are breaking the page JavaScript. If you can get that loaded over HTTPS, the issue should go away.


Thanks for looking that over.

How could I go about forcing beaverbuilder to fully HTTPS? It does this just fine from the main multisite… but I’m unsure why a subsite would be different.

I’m forcing the wp backend to go over ssl through the wp-config way. I have tried using “wordpress HTTPS” and “SSL insecure content fixer”, while they make other things behave better, they don’t seem to affect BeavBuilder.

I also looked at frontend.js.php to see if I can hard-code the https into the addresses, but am unsure if that will do anything as the twitter script already says https…

What would you do to make this work?

This was a somewhat similar issue fixed( ), but not quite the same because my ssl issue is with subsites and facebook/twitter.

I’m not sure there is much I can do without modifying plugin source, which is something we generally hope not to do. Is this something that needs to be officially updated in the plugin?

Hi Carmelo,

Beaver Builder isn’t actually loading in the Facebook and Twitter scripts. It looks like those are coming from the Social Marketing plugin. They’ve either hardcoded HTTP versions of those (which they need to fix) or your HTTPS setup isn’t quite right. My guess would be the latter as that’s a common mistake.


Oh snaps! It was the social marketing WPMUDEV plugin. I’ll need to either omit this plugin or fix the ssl issue.

Thanks for your super help! I appreciate it. I will consider throwing a party now.

Glad to help! Have fun at that party :slight_smile: