Error: Uncaught ReferenceError: FLBuilderConfig is not defined

Hi guys,

I’m getting this error.
My content in the builder is a row with a HTML piece (just a shortcode) and another row with a revolution slider in it!

That’s all!

Can you tell me what’s going wrong?
I had to delete the page because the builder isn’t loaded so i couldn’t remove a row.

Okay so i know a bit more about the problem!
The problem is then using a shortcode.

In the shortcode i’m using a loop
<?php while($results->have_posts()):

This is the place where things go wrong.
When removing the have_posts while the problem is solved!

Tried it in another websites and there is the same bug!

Hey Jurgen,

Good to hear from you. Can you check and tell me which version of the plugin you are using by chance? Do you have the latest version?


Nu Billy,

Yeah im using the latest version. I’ve downloaded it today

Interesting. Would you mind sharing temp login details via private reply so we can take a look?


[Content Hidden]

Thanks Jurgen, we’re looking into this.

Just wanted to chime in here because I have had the exact same problem and have just managed to fix it for myself. The issue I had was that I had a loop in a module, but did not use wp_reset_postdata() to clean up after it finished. When I added that, all went well.

  • Lewis

Cool! Thanks wpkonsulterna! It worked!

And thanks to the beaverbuilder team for helping me out!