Error When Importing a Template From One Site To Another

Hi there - I created a template using Beaver Builder on a site. My plan is to import this template from one site to another site. I am able to export just the template itself, however, once I import the file it generates an error message that says:

Sorry, there has been an error.
There was an error when reading this WXR file

I have filtered out some possible ways to fix this by deactivating all plugins but still not working. Can someone help with the best step to get a template imported into another site.

Is there one or more blank lines at the top of the export file?

1 Like

Hi, i was able to import it after removing the blank line, but when I go to edit the template, it’s blank…any ideas?

Anyone have a fix for importing templates from my previous comment?

Import the template in .dat format and upload it . It will work.

How do I export the template as a .dat file to then import? It only exports as xml.

There shouldn’t be any need to export the template via a .dat file. If you exporting your templates using the WordPress export tool and importing on your site and receiving a:

Sorry, there has been an error.
There was an error when reading this WXR file

Then you likely have white space somewhere. If you’re using a child theme switch to the parent and export/import and see if the issue persists.

1 Like

Hi Danny - Yes that was the original solution that I tried. I removed the white space and it imported, HOWEVER, the template is blank. (As if it looks like it’s just a new template).

I’ve tried switching to a blank theme, parent theme and nothing works.

Can you contact our helpdesk so one of our support team can take a closer look.