Fatal Error - Maximum function nesting

I just purchased BB & I’m just playing on my local Windows PC using WAMP
But I keep getting this error :frowning:
I originally had your supplied theme installed - I also removed that and installed Genesis & it worked OK for a while, but then when I added a third row - it blew up again.
TIA, Dave

Most recent error:

Fatal error: Maximum function nesting level of ‘100’ reached, aborting! in C:\wamp\www\beaver_play\wp-content\plugins\bb-plugin\classes\FLBuilderModel.php on line 555


Can you try changing your theme back to the Beaver Builder theme or any of the standard themes like Twenty Fourteen and see if you still have the problem?

You can also try turning off any other plugins you might have installed too.

Also, are you using the Genesis base theme, or another Genesis child theme?


Hi David,

My apologies for the hassle. We just released version 1.4.1 that contains a few bug fixes. Can you try upgrading to that? Send over any new errors if the issue persists and we’ll have a closer look.

Thanks for the help, Colin :slight_smile:


Thanks Colin & Justin,
I will certainly give that a try…
Regards, Dave

I am having the same troubles with WAMP and Beaver Builder. I have tried the following themes: Twenty-Twelve, Genesis with Sample Child Theme and the Beaver Builder theme. All with the same results. I have made PDFs of the pages with showing the error table - how would I send them to you?

I was able to edit the sample themes; however, with the latest builder the sample themes aren’t showing up on my page.

I would love to be able to use this plugin, but not being able to develop locally doesn’t fit into my workflow. I hope you can find out what is causing the issue.


I’m sorry to hear you’re still having problems. I just googled your error and it seems to be quite a common occurrence in WAMP. Here’s the best page I found that offered numerous solutions to the problem you’re having.


If none of those work…

I have used XAMPP for the longest time and have never had any issues at all with it. If you don’t have many local sites, may I suggest giving XAMPP a go. It’s a little more powerful than WAMP and also provides a lot of other advantages. It will also most likely solve your local development issues.


I hope that helps.


Hi Sue & David,

Sorry about the trouble with this. After doing some research, it looks like the first step would be to comment out this line in your php.ini file:

"zend_extension = "d:/wamp/bin/php/php5.3.8/zend_ext/php_xdebug-2.1.2-5.3-vc9.dll"

This was the “correct” solution on the SO post that colcar linked.

Be sure to restart WAMP after commenting out that line and please let us know if that solves the issue. Thanks!

Hi everyone,
Sorry for delay in getting back to follow this up…
I tried 1.4.1 but that made no difference.
I checked out the StackOverflow article and I tried changing the line:
xdebug.max_nesting_level = 250
in my php.ini file and that seems to have sorted it out :slight_smile:

Apart from the error - I was also not getting the Layout Templates to appear, but now they work fine.

Thanks again for all the help & input.
Regards, Dave

That’s awesome Dave:)

Thanks for letting everyone know what fixed it for you.

Sue, can you try editing this line in your WAMP php.ini file:

xdebug.max_nesting_level = 100


xdebug.max_nesting_level = 250

That should also resolve your problem.


No worries Colin,

And just to clarify - I had to add the line, it did not exist.
I added it below all the other xdebug lines - like this…

xdebug.remote_enable = off
xdebug.profiler_enable = off
xdebug.profiler_enable_trigger = off
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.profiler_output_dir = “c:/wamp/tmp”

xdebug.max_nesting_level = 250

To get to your php.ini file - single click the Wamp green icon in your system tray, hover over the PHP section and select php.ini - this opens it in notepad for editing.

Then restart all services.

Cheers, Dave

Thanks for all the help - I commented out the suggested line and now everything is working fine. I just added the increased nesting level for good measure.


Thanks for letting us know Sue. Glad everyone is all up and working:)