Full Width Rows Template

I’m having trouble setting up full width rows on my site - I’m using the Genesis framework with Dynamik child theme, and the Beaver plugin. I used the code from the tutorial on http://dynamikbeaver.com/blog/set-dynamik-beaver-builder-full-width-rows/, but it’s not working for me. I’ve tried searching in the support forums, and not found a solution. Please help.

Hi Scott. I’ve used exactly the same code recently on a site and it worked perfectly. I assume there might be a CSS conflict in your site. Do you have an URL to check?

Regards, Leo

Here’s the site I’m working on: http://jennie.rainierdev.wpengine.com/

Hey Scott,

I’ve really no experience with the Genesis framework but I couldn’t help but notice, the markup of your site is different than that of a Genesis framework. For instance, the full theme demo found on their site uses something like this:

<div class="site-container">
	  <div class="site-inner">
    		<div class="content-sidebar-wrap">
      			<main class="content">
<!-- closing tags here -->

But yours doesn’t have a site-container nor a site-inner class. It also doesn’t have a content class but instead have a content ID. This makes all the difference since the CSS above targets those classes. This just led me to believe that maybe you are using a different version of the same theme or using a different theme altogether?

Hope this makes sense.


Thanks, Ben - I combed through the Dynamik settings and there was a checkbox to “enable Genesis markup” that wasn’t checked. That fixed it!

Just saw your latest post - so forget my remarks.

Hi Scott,
your template themes to be Bootstrap due to the classes. But your footer says Dynamik Website Builder. DWB is no framework but a child theme to Genesis. So Ben is right. If you want to make the CSS work you need to change the class names in your markup (or use Genesis).

Regards, Leo