Not Working Correctly on WPEngine


I saw the thread on the Builder not loading ( and have a slightly different problem so I decided to start a new thread. FYI, I also have WPEngine looking into this from their end.

Builder worked correctly on my local dev XAMPP and seemed fine on WPEngine’s staging server. When we pushed it live we could load the Builder but when you clicked to edit a section it hung on the loading sequence. (BTW, using most recent of both the template and plugin.)

I’m seeing 2 errors appear when I click the wrench to edit a content area, this is what comes up in the console:

GET…bb-theme-child/fl-builder/modules/post-grid/js/settings.js?_=1421791066128 404 (Not Found)

Uncaught SyntaxError: Unexpected token <

I know that the referring url in the first one is incorrect but I can’t find that anywhere in the DB using the search and replace script. FYI it should just be

I’d be happy to create a test account for you so you can see it in action. This is an issue on every page

On what may be a related note, I was going to try to completely uninstall the builder using the button in the Settings area but when I do the server returns a 502 error on WPEngine and this error on my local setup: Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 130968 bytes) in /Users/ddabney/Documents/Websites/ on line 798

Sorry for the long post but I wanted to make sure I cover as much as was known this point.


[Content Hidden]

Thanks so much, David, and sorry to hear about the issues. Would you also be able to provide FTP access as well?


[Content Hidden]

Thanks, David. I tried the wp-admin login and it doesn’t appear to be working. Can you check that out?


The login should be working now. Give it a shot.

Very curious as to what is causing this as I am considering moving a BB-enabled site to WP Engine soon.

I use BB on WP Engine with no issues.

Thanks, David. I’ll be looking into this shortly.


Hey David,

The FTP info doesn’t appear to be working. Can you check that.


[Content Hidden]

I’ve also created a screencast showing the problem with editing through the front end editor:

That worked! I believe the issue is tied to a bug that we fixed but haven’t released yet for overriding custom modules. Hopefully I can get this fixed quickly for you!


Thanks Justin, I appreciate you looking into it so quickly.

Hi David,

My apologies. I thought I had followed up yesterday but I guess I didn’t! Your site has been patched with the fix and everything should be working as expected. Let me know if it’s not.


Excellent, thanks! Everything’s working correctly again.

Moved Mike’s reply as a new topic -