Number counter - problem with units and decimal places

Want to use number counter to display as follows:

lorem ipsum dolor

Can’t for the life of me work out how to do it as:

a) The number 2.8 is being rounded up to 3
b) there is not field for units. I need a unit to appear logically in the same way the % sign does but if I enter 2.8k it spits it out and renders as 100.

Sure I’m missing something obvious (new user) so would appreciate any advice.

Many thanks.

Hi Mark,

Unfortunately, the Number Counter module is a counter and so it doesn’t support decimal in the numbers field option.

If you have a moment to spare, please feel free to add this to our UserVoice as a feature enhancement.

In regards to your custom unit position question, you could select the Standard from the Number Type option and then in the Number Suffix option add your unit value. This will then appear to the end of your number value.