Responsive video missing div class on local server


I used the video module (embedding a youtube video) on a dev site. It does seem to work as expected: it has the right ratio and it perfectly behaves responsive (whatever the column-width I am placing it in), but when viewing it on the front end it’s ratio (and therefore the responsive behavior) is completely different.

But now the weird thing: this is on my local dev site. When adding it on my staging server it does work as expected. The difference being that on the staging server the video gets an extra div around it, with the class “fluid-width-video-wrapper”. This div is missing on the local install.

Note that the staging is an exact copy of the local install. Both using 1.6.3 beta of BB.

Very curious to what would cause this to happen… :-S

Hey Tibor,

I tried the same thing, video module on a Youtube video on my localhost and it’s working fine. I mean that wrapper is there. I guess this boils down to the configuration you have on your localhost. I’m running XAMPP, didn’t change anything since installation. :slight_smile:


[Content Hidden]

Hey Tibor,

Sorry but I can’t seem to visit the page. Getting a fatal error. Are you working on it? Regarding the issue, if it works on another page, it may have something to do with the content on that specific page. You could try saving the problem page as a template so you have a copy of it. Then try removing the content one by one and see if you can find out what it is that’s causing it. Or you could send temp admin access so we can check as well.


Hi Ben,

You must have tried to visit just when I was (manually) updating to, just now.

Good news is that the problem seems to be solved: both examples work as expected now. Same goes for my local version…yay :slight_smile:

As for your last reply: I did some tests removing content, but so far without any succes. If the problem might reoccur (which I expect not) I’ll get back. Until then, let’s just blame it on the beta :wink:

Thanks for your assistance anyway!

Hey Tibor,

Glad it’s working fine now! Hopefully, it was just part of the column bug we fixed on the latest patch. Enjoy BB! :slight_smile: