White Screen!

Help! I just took a site live and after I made some changes to some links in modules I got the white screen of death! This site is hosted on Flywheel. I opened a ticket with them, and here’s what they said:

It appears that the Beaver Builder plugin is causing the site to whitescreen. We have temporarily disabled it so that the site is back up and will allow you to login.

It may be worth checking with Beaver Builder to ensure that the plugin is compatible with the latest version of WordPress and your current theme. Otherwise, we could definitely roll back the current version of WordPress to a previous version to ensure that the site is working properly.

It doesn’t seem like that’s the problem to me, since it worked before I made updates to some links, but that’s all I have to work with. Thanks in advance for your help.

[Content Hidden]

Hey Fran,

We can take a look at the issue. Could you provide temporary FTP access as well?


[Content Hidden]

Thanks! Checking this out now.

Hi Fran,

You’re all set! It looks like the issue is that you still had images pointing to the .org address instead of the .net address. Normally that’s not going to cause a white screen, but for some reason, FlyWheel is hanging because of it when we use the wp_get_image_editor function.

Anyhow, to resolve that, I replaced the URLs using…


Let me know if you have any questions.


Thank you so much, Justin!

I knew it must have something to do with that, but I’m not technical enough to figure it out on my own. I will let them know.

Thanks for the plugin recommendation, I just found that today (a little too late for this site) and I’m going to need it for another site I’m about to take live. Beaver Builder is making me very productive!!!

Thanks for everything, you guys rock!

You’re welcome! I’m glad to hear that Beaver Builder is working out well for you :slight_smile:

Aacck! I just logged into the site and all of my inner pages are now within index.php folder. So, instead of miitek.net\business-analysis it’s under miitek.net\index.php\business-analysis.

How the heck did that happen? Maybe something Flywheel did? I’ll ask them too.

Hey Fran,

Did you figure this one out? I think it’s only a permalinks issue. Head over to Settings > Permalinks and remove the index.php part if there is one.


That did it! Never seen that happen before. Thanks Ben.

No worries! I’ve encountered hosting companies implement that before. I’m not really sure, I just remove it there and it just works. :slight_smile: Enjoy! :slight_smile: