Access to "Theme Appearance > Customize" not working


Your team has done a great job in building this product - we have launched successfully our company website - however i had to go back and make some revisions to the website and came across this error:

  1. Login to website backend
  2. Click on Appearance > Customize
  3. I get the following error:

PHP Warning: Creating default object from empty value in C:\Inetpub\vhosts\\\wp-content\themes\bb-theme\classes\class-fl-customizer.php on line 437

  1. Line 437 in the php file is the following:
    $nav->panel = ‘fl-settings’;

We have a produciton site where we do our testing before it goes live [] - and in the backend I have acceess to the Appearance > Customize. I looked at line 437 and it is exactaly the same.

Please advise.

THank you.

Hi Goldstein,

Sorry to hear about the issues and thanks for the kind words! This sounds familiar and I believe it has something to do with the Beaver Builder caching. Can I have you try modifying something in the customizer, not to change a setting on the live site, but just so you have the ability to re-save the customizer? From there, go ahead and go on over to settings > page builder > cache and clear it? Let me know if that helps!


Hello Billy,

I cannot even get to the Appearance>Customize section, so performing edits within that section is not possible.

Appearance> Themes
Appearance> Widgest
Appearance> Menu
Appearance> Editor

all work.

I went ahead and cleared the cache - however the same error is occuring.


thank you.

Interesting. Can you send us temp admin access via private reply? We may also need FTP just in case. Thanks!

[Content Hidden]

Hi Goldstein,

Unfortunately, we do not offer phone or remote support at this time, sorry about that. We can only troubleshoot further with proper access.


Hey Goldstein,

Just wanted to chime in here. What version of the theme are you using? We had an issue similar to this that was fixed since Maybe try updating to the latest version of the theme first and see if that fixes it?


Thx Ben Carlo

Hey Rodrigo,

Glad I could help! :slight_smile:


Ben & Billy,

Thank you for that tip - i upgraded the theme version and it fixed that glitch.
problem solved -

thank you for the support.


Awesome! Glad it was that simple! Enjoy BB! :slight_smile: