Anchor links not working on small devices and between pages

Hi I have created anchor links on my home page. Basically if someone clicks on some of my menu for example the about page it would direct them to a section on my home page. This is only working on the desktop and on tablets in horizontal view. I cant get them to work on small devices. Also when I am in my contact us page, for example, if i click on the about part of the menu it goes no where. I have added the word “about” in the ID section of the advanced tab of that particular content band on the home page and then added #about to the url in the custom link in menus part of wordpress desktop.
Could i please get some help with this?
i have now added to the dashboard menu the full url with /#about at the end so it will navigate from a subpage to the about page on the section on the home page. On the mobile it will take me to the home page but not to about section. Still no fix to navigate the menu about to the about section of the home page though :frowning:

Do you have a URL? I did a test on a test site, it works fine on mobile, so then we have to start looking at details, ideally if we could see it and test it ourselves.

Hi Yes my site is floralyourbrand.com.au. Also when i shrink my desktop screen the jumps no longer work. So i can rule out an ios or safari issue.

Thanks that helped me try to replicate more precisely, and I still can’t replicate it in Safari or iOS. One thing I noticed is that even with the straight URL on your home page (https://www.floralyourbrand.com.au), the About link is selected even though the anchor doesn’t appear in the URL. This is happening in every browser, so it’s not Safari, and I think I replicated your Customization of a right flyout with opacity hamburger menu in the Beaver Builder Child Theme, so it’s not that either.

This doesn’t happen in my replication, which you can see here (sorry it’s ugly, it’s my test site): https://ss-sites.com/bb222/ . The ‘Map’ link goes to an anchor on the home page, and you can see that only one menu item at a time is highlighted, depending on what appears in the URL.

If I inspect the code for both pages, I can see that both of your menu items are highlighted because they’re both being given the css classes for current menu item and current page item, whereas my page is a little different. I just don’t know why it’s happening that way. Have you filed a BB Support ticket? They would be better able to sort this out.

Here are some screenshots:


I saw your site went down for maintenance and now that it’s back up, ALL the anchored links in your menu on the home page are highlighted. That seems like some kind of clue–if you changed something, that probably wasn’t a good thing LOL.

Also it looks like you’re using a right flyout overlay, not a push, so I changed that setting in my site, but it still works fine in all browsers and on mobile.

It went down briefly because i backed it up through my hosting. did that just in case i buggered it lol. Can i ask is you home page a custom link page or a actual page? Mine is a custom link and i thought this may have been the prob? though i did add the actual page to the menu but didnt solve it and i kept the custom link and just moved it to under the contact us page. ive not long out a ticket in so will see what they come back with.

Home page is an actual page. https://share.getcloudapp.com/4gu7qj9A

I really don’t know what the difference could be but if you find out from Support, please report back here, would be good to know.

Ok great glad I had that bit right then. Will do. I’ve noticed through the community posts about anchor links that are few people are having difficulties with them working on small devices but no one seems to give the fix.

You have three divs with the ID about so the browser does not know which one to scroll to.

The divs are set to different devices lrg, med and small. I couldn’t get the site to be responsive if I didn’t do it. Didn’t have to do this on my other site (no anchors on that one). I’ve tried it just with the one ID on one Div but it still didn’t work. The BB theme people are in there now and they can’t seem to work it out. Maybe next week they will work it out.

The URL changes but nothing happens even when I only had 1 ID.

I believe this is a Google Chrome bug. Can you check in another browser such as FireFox and see if the issue persists, please.

If it does, can you contact our helpdesk. :slight_smile: