Background Image URLs in stylesheet not updated when moving site to new URL

Hi guys,

Once again, thanks for the great work on this awesome plugin!

I’m running into a problem when migrating my site from localhost to a live URL.

I run this search/replace script to update all URLs within my database:

Everything works fine except for instances of Beaver Builder modules that have an image set for the background. It appears that those background images are written into a stylesheet that lives at a URL as follows: /wp-content/uploads/fl-builder/10-layout.css?ver=fad9f…etc…

The only solutions that I can see to fix this are:

1.) Open up the page builder page-by-page and manually replace the images.
2.) Download the offending CSS file and run a search/replace for all instances of the incorrect URL.

Am I missing something here? Is there a way I can get Beaver Builder to automatically update and rewrite those stylesheet URLs when I migrate the site? Any help in automating this process would be greatly appreciated.


Hi Evan! Which search/replace script are you using? We recommend using this one: as it handles serialized data very well. Let me know which script you’re using and we can go from there. Thanks for the kind words by the way. They’re much appreciated!

Hi there. Apparently the link I pasted didn’t make it into the final version of my post. My apologies.

I’m using the exact script that you mentioned. It works totally fine and correctly updates all of the URLs that you would expect it to.

However the problem appears to be with links that are hard-coded into stylesheets which are automatically generated by the Beaver Builder plugin.

Is there some way within the options of the plugin to have it regenerate the links within these CSS files? Apparently running the InterconnectIT plugin does not do anything to tell the plugin that the URLs within the stylesheet(s) need to be updated.

Let me know if this makes sense.


Yes! This makes perfect sense.

You can manually clear the cache and that will force BB to regenerate those styles with the correct URLs. To do this, you’ll want to clear out this folder: wp-content/uploads/fl-builder/. You might as well copy everything in that folder to a local folder (as a backup) just in case. But, you shouldn’t have any issues with just wiping the contents of that folder, and that should clear up the issue you’re having.

Thanks again for reaching out, we’ll probably add some info about this in our documentation.

Let me know if you still have any trouble.

OK sounds good.

So to confirm, if I simply backup and wipe out everything in the wp-content/uploads/fl-builder/ folder, all of those files will be automatically rebuilt with the correct URLs once I load the site?

What will trigger the rebuilding of those files? Browsing the site in the front-end? Or do I need to fire up the Beaver Builder editor within the admin panel in order for it to happen?

I only ask because I want to minimize downtime and errors when I move the website to the final, live URL.

Thanks again!

That’s correct, backing up and wiping the uploads/fl-builder folder will clear the cache.

Everything should be regenerated when the page is loaded on the frontend. You should not need to activate the builder or anything like that.

Thank you for confirming.

For what it’s worth, I DID NOT experience this issue when moving my website from staging to production URL. It’s weird, as I’m pretty certain I didn’t do anything different. Maybe something I did inadvertently cleared the cache folder.

The issue originally occurred for me when I moved the site from localhost to staging.

If I notice any additional issues related to this in my work I will keep you guys updated.

Interesting. I will have to ask Justin as he wrote this piece, but I wonder if this has to do with the way the cache is generated. If you were actively working on a page on the local server, it might not have been cached until someone tries to view it on the front end. I imagine you or your clients were reviewing the pages on the staging server which would cause them to get cached.

Anyways, glad the issue is resolved! Definitely do let us know if you notice any additional issues.

My cache is NOT clearing. It keeps using the old url which is http and I need it to be updated to https

This is kind of a big deal. And I need to fix this asap because we just launched the site.

Hi Nicole,

When I view your page source, all cache from the BB plugin, is using the HTTPS version. Are you not seeing this?


No, for me everything is still looking at http sources.

Can you try and install WordPress HTTPS and see if this helps. I am sure there is an option to Force SSL, check this and then clear your cache again.


I’m hosting with WP Engine and that check box is already set. It’s also still accessing the old url with wpengine in the url.

Hi Nicole,

Can you provide temp admin access to your site, so I can take a closer look, please?


[Content Hidden]

I updated some manually and now I don’t think I have any more issues. It’s strange tho, that I had to do that.

Hi Nicole,

I’ve logged in and cleared the BB cache and I am not seeing any image, loading from HTTP://. They all appear to be HTTPS://.


Yeah, I think it’s all fixed now.

Awesome. Happy to hear you issue has been resolved, Nicole.