BBuilder hangs and does not save edits

Site with BB plugin and BB theme.
WP 4.4.2 and BBuilder 1.7.3 (updated to 1.7.5 today)

Yesterday the client was adding logo’s to a page with quite a lot of logo’s. At some point the BBuilder did freeze and the client had to close the screen.

Today I tried editing the page and at first I only could publish the edits after I removed a logo. After that the edit (adding of logo) worked and the page could be published.
After that editing another logo made Bbuilder freeze and I closed the screen after few minutes.

Now when I add another row (duplicate) and publish the edits aren’t saved.

I increased PHP memory from 128 tot 256M and cleared BBuilder cache.
This does not help.

What could cause this, where to look for?

[Content Hidden]

Hey Edwin,

I went in to the page in question, changed the first logo on the top left with another one and it works fine. Do you mind listing down the steps to recreate the issue?


Hi Ben

Thank you for diving in.

Client wants to add more logo’s and remove the list with links underneath all the logo’s.

The issue arises when a row is added. Please try to duplicate a row it will appear underneath. Then click done and publish it. You’ll see that the edit is gone.
When you copy a module with text it is working okay. This edit can be published.

And I experienced that when I added a few rows extra the builder hangs.

Tried in Google Chrome and Firefox but that is not the issue.

Hi Edwin,

So we can recreate your issue correctly. Would it be possible for you to record yourself recreating the issue, please?


[Content Hidden]

Hi Edwin,

The reason as to why I asked for a recording showing you recreating the issue. Is because I am unable to do so. Before I posted my reply above, I was able to replace a logo image and add a new one. I reverted my changes before posting.

However, I have gone ahead and replace the first four logo image with other images from your library. This time I have left my changes so you can see what I have done. When I did this, BB worked as intended and didn’t hang or prevent me from editing the Photo module.


Hello Danny,

I have made a recording with stepsrecorder (programm within windows) and have send you the link where you can find it in the private reply.
I don’t have any other recording software.

Changing a logo isn’t the problem. And the issue with BB hanging occured once when the client was editing and once when I was editing after the client mention this and I wanted to test and recreate the issue. Problem is not publishing a new row with logo’s.

The problem arises with publishing when adding a complete new row to the page. Try adding a row and adding a photo module and a logo. In the Builder mode it is working. But right after you click done and publish the new row is gone.

So steps:
In Builder mode: duplicate row (the row appears underneath)
Click Done
Click Publish Changes

The new row is not published and is gone.

Thank you for looking in to this.

[Content Hidden]

Any news on this issue?

The orginal site needed to be ready this week so I have used the plugin Logo Showcase from Carlos Moreira to display the logo’s. This plugin comes with an carousel slider and responsive grid and has severaklothers options. This fits the needs very good.

But that does not solve the issue there is with not being able to publish a page when adding rows with images.
So could you tell me if there is any news on determining the cause of this issue?

Hi Edwin,

I have recorded myself, both duplicating an existing Row and adding a new Row/Photo module. Then I upload an logo image to that Photo module and save the changes via the Done button. I experience no issue or hanging with the page builder UI.

Therefore, I was unable to recreate your issue. I also apologise for the delay in our response. I have been trying to recreate your issue, but was guessing. As I was unable to open the file your provided. The file appears to be a .mht file which as far as I am aware isn’t a recording, but a saved webpage in IE?

You can see my recording here -

If I have missed anything to recreate the issue, please let me know.


Hi Danny

Thank you for your response and effort.

I have found a tool that can record my screen. You can find a recording here:
I edited the page businessclub and you will see that the issue persists.

From your recording I see you tried to recreate the issue in a other page. My impression is that is related to this particular page or caused by the amount of images (image modules) on the page.

When the client was working on the site the screen froze at some point and after that edits could not be made. After he mentioned it to me I tried to edit and did experience that the page froze and edits were not saved.
At the moment I don’t experience that the page freezes but the issue not saving edits persists.

Hi Edwin,

I’ve looked into this further and I don’t think the issue is happening on the bubble site. I think the issue is the other site. The images you’re attempting to clone all appear to be coming from the other site.

The issue appears to be cache related. However, so we can diagnose this more thoroughly, can we have temp admin access to the clients site, please.

Also, are both sites with the same host or on the same server? If so, can you contact the host and ask them if they’re using any server side caching.


Hi Danny

To clarify, the video I recorded is from the bubble site. This site I have cloned from the orginal site after first contact with you. It shows the same issue as the original site did.

So giving the credentials of the original site would not be helpfull and any testing would be bad timing. Reasons:
The client is sending out an directmail to businessclub members
And on the client’s site we swapped the bb photo modules for an plugin “Logo showcase” for the display of logo’s on the businessclubpage. (and in a carousel slider)

Both site are on the same server (a managed VPS)
I will contact the hosting provider if any server side caching is beeing used.

Thank you

I got confirmation from the host. The server does not use server side caching.

Hosting provider responded again. They checked the logs but couldn’t find something related to the issue of the freezing. A cause they mention that could might lead to freezing could be a time-limit or memory setting within PHP. But the issue of freezing is some time ago, so that would not be found in the logs anymore.

And that does not explain why the edits aren’t saved.

When I find the time I will move the bubble site to another server to test it there. But that would a downgrade from a VPS to a shared hosting server.

Hi Edwin,

We have assigned your topic to one of our developers who will look into this further for you.


Hi Edwin,

I found the issue and will have a fix available in the next minor update. If you want, I can patch your site now, just provide temporary FTP info.


[Content Hidden]

Thanks, Edwin! You’re all set. Let me know how it goes on your end.