Beaver Builder Edit Menu not appearing

Hi, when I put custom HTML into a page in Beaver Builder it causes the Beaver Builder Menu to diappear and is replaced by black boxes, this is what I see now:

It happens after I ad script references to some jQuery style sheets, as if beaver builder can’t load with the CSS conflict?

Is there anyway around this because I need to use jQuery style sheets on this page.

We need more info, like what exactly you added, or a link to the site to see the error 1st hand. Its almost impossible to debug a screenshot of something that is missing. Imagine sending the police a pic of your empty parking space after you car got stolen :wink:

1 Like

Here is the page in question:

Not sure which CSS causes this because now I can’t look into the custom HTML module but I think it is this one:

In another page, the same thing happened when I added this jQuery reference:

It seems like this website is deleting my code when I paste it.

To further your analogy, imagine trying to report all the details to the police but every time you write the details it gets magically erased.

Here you can view the code:

Yea I doubt css is the issue. Open the developer console for your browser then recreate the issue then show me the result.

When I open the page in beaver builder, this is everything developer console says:

Screenshot (see below for all text version):

And all text version is here:

This is most likely your issue, 2nd version of jquery in the page:

Thanks. I know it is an issue with some jQuery reference are you saying I can’t use jQuery?

It seems jQuery is loading twice in the page, which probably triggers a conflict. BB already loads jQuery, you should inspect which extra plugin loads the second jQuery occurrence and try to disable it.

No … using jquery is perfectly fine, its already in the page provided by wordpress, your issue is that you are loading a 2nd version in the page which breaks all jquery scripts that use it.

Ah yes, it’s WordPress loading jQuery by default, not Beaver Builder, my mistake. :wink: