Beaver not working on our custom theme

We installed on our dev site for testing -
WP 4.1.1, Beaver 1.5.0
Tried Beaver on existing pages, no luck.
Created a new page, also no luck:
Browser: Chrome 40
OS: Mac OS
Will add logins via private reply. Thank you.

Hey Cody,

Sorry to hear about the issues. Have you tried the plugin route beforehand to ensure it isn’t related to a 3rd party plugin, i.e. disabling all plugins to test BB? If not, please give that a shot and if BB is working, start re-enabling each plugin while testing BB to see if you can pinpoint which may be giving you issues. Thanks Cody.


Sorry, I should have mentioned that. Did not work with all plugins disabled.

Thanks Cody, I’m getting the same with plugins disable and enabled. We’ll take a deeper look soon!

Hey Cody,

I’m getting a white screen on every page of the front-end of your website. Are you working on it right now?


You had activated two plugins we had been testing/comparing, but aren’t using - which would have caused conflicts with each other. I deactivated them, so please try again.

Hey Cody,

Thanks for that. I’m jumping in there now.


Hi Cody,

It looks like you have a query that isn’t being reset in your footer.php file on line 21. This is altering the main query which the builder needs to know which post to edit. When using query_posts it’s always a good idea to run wp_reset_query(); when you’re done. I’ve added that for you at line 34.

I also noticed that you have a few JavaScript errors in Chrome’s console. They don’t appear to be breaking the builder but it’s possible they could cause a conflict somewhere.

Let me know if you have any questions!


Thank you so much!! We will take a look and I’ll send over to our developer as well.

You’re welcome! Happy to help :slight_smile: