Bold text not working in text editor

I would like to have only one word in Bold in text editor.
As soon as I change font or change size, it is not longer showing bold text anymore. Even though in text editor is in Strong/Bold.

Somehow something is overruling it. What can I do to keep one word in bold?


This is a known bug when you’ve set the font-weight in the Text modules Style tab. If you set the font-weight option the text you’ve bolded should now display correctly.

Hi Danny,

I don’t mean to hijack but I had this same issue and found that your fix worked for me – I had weight set to Normal and when I set it back to Default, I got my formatting back. One problem, though – it seems under some circumstances there is no ‘Default’ weight option listed. Specifically, I’m using Noto Sans in a text block and I am only offered Normal and Bold options.

Even if I set the font face back to Default, which then adds the full range of weights to the weight selection menu, including Default – if I select Default and then change the font face back to Noto Sans, the Default font weight option disappears and weight is set to Normal.

I assume the Default option is a function of BB and not something related to Google Fonts functionality. Could that be a bug?


The google ones, we only show what is provided by google. There cant be a default.

Hi, I am new to building pages with BB. I created a webpage and within a text block I bolded some texts, and in the Text editor they were all shown bolded with . Yet, when the page is viewed, certain texts were not bolded. No matter what I tried, unbolding and re bolding again, still certain text will not bold.

Is there still a bug in BB after all these years? Danny of the Beaver Builder Team said this is a known bug in 2020.

I asked website hosting company for help and they said they do not deal with software bugs.

Hope to get some help in this forum. Thanks!

A link to the page would help