Child theme customizer not loading (or actually infinitely)

Hey guys, my first serious problem: the customizer is no longer loading for me. No errors or anything, it just keeps on going and going without displaying anything. It is still loading no problem on the parent theme however.

I deleted and reïnstalled the child theme, but to no avail. Also the header and footer no longer seemed to display. I’m guessing something got corrupted in the options file somewhere, but I have no idea, where and how that is structured.

FYI, I’m not running a caching plug-in. Also FYI, I might have been editing a bit too aggressively from two screens at the same time. I’m happy to give full acces to the site and sFTP.

Hoping you can help me, as I’m planning on launching very soon! I backed up most of my files by the way, but not the full css en scripts in the editor (that I can no longer access nor find), so recovering those would be great as well, but not too big of a deal.

Found this error in the console:
Uncaught TypeError: Cannot read property ‘container’ of undefined

Regarding this part:
* Initializes logic for settings presets.
* @since 1.2.0
* @access private
* @method _initPresets
_initPresets: function()
api.control( ‘fl-preset’ ).container.find( ‘select’ ).on( ‘change’, FLCustomizer._presetChange );

Hi Kevin,

Have you tried disabling all active plugins? If not, do I have permission to do so, please?


Did it just now. No effect. You have permission to do whatever you think is necessary, not getting anywhere anyhow :).

Hi Kevin,

Did you add any custom scripts to the Customizer?
If so, what were the scripts and where did you add them?

Can you switch theme to the BB theme and see if the issue persists?


Everthing works when parent them is used (I mentioned that in my first post). I’ve added 2 scripts. They have never caused any problems, but I added a comment (at least I meant to). Maybe that messed something up. Edit: google analytics and facebook sdk scripts. Thanks for your prompt responses by the way :).

Oh, and I think it was 1 script in the head and 1 the header.

Hey Kevin,

It looks like the comments you’ve added to the FB SDK Script weren’t closed, and I believe this is what’s causing the issue. All of the scripts that run after it are being regarded as a comment so they’re not loaded. I’ll post in a separate private reply a screenshot for reference.

I’ll get in touch with our lead dev and see if there’s something we can do about it.


[Content Hidden]

Oops, that should exlain it. Thanks for looking out! I also have access to by the way. Not sure if useful here.

Looks like I fixed it! For those who - like me - might mess things up at some point, here’s how I did it:

  1. Go into your MySQL database (via phpmyadmin)
  2. Query “theme_mods_bb-theme-child”
  3. Back-up the entry!!
  4. Open & edit it (it’s readable in plain text)*
  5. Save!*
  • I think last 2 these steps should be possible, but somehow the file reset to blank when I did it. So in my case, I just deleted the entry entirely. And got a fresh start the regular way (from within the front-end customizer). Luckily I backed up the file, so I could just copy paste or look up all the stuff that I needed. Hope that’s useful for someone in the future (or actually I hope everyone would just close their comment tags).


PS: is it possible to delete my post with user/pass info? I’m resetting them regardless of course. Thanks!

Hey Kevin,

I was gonna give you that as a last resort, since our lead dev is pretty swamped with bugs this week. The reason why it reset to blank is because those data are serialized. If you add/remove characters, you have to update the serialization as well else the entire code would break.

Anyhow, thanks for taking the time to inform us how you fixed it! We really appreciate it. :slight_smile: