CloudFlare, MaxCDN and BeaverBuilder

Hi - I’ve searched the forums and can’t seem to find a solution to my issue. I have a page that I created in BB. I have buttons on the page with different background colors. During dev, I deactivate CF and all is fine. A day later, when CF is activated, the buttons do not show any of the css that I set in BB. All buttons are white with black font instead.

I’ve tried clearing cache on site (WP Super Cache), MaxCDN, and CF. I’ve tried turning off minify css on CF, SSL, etc. I don’t have Rocket Loader activated on CF. Nothing works except putting CF in dev mode.

Any suggestions? Thanks in advance - your support team is great!

Hey Julie,

Welcome to the BB forums! :slight_smile:

Do you know if your site has server side caching setup? If so, can you try disabling or clearing its cache as well? Also, it’s not mentioned above, can you try clearing the BB cache as well under Settings > Page Builder > Cache?

Also, can you share the URL of the page in question along with temp admin access so we can check? You can post the details here using the private reply option below.

Lastly, thanks for the kind words! We really appreciate it. :slight_smile:


Hi Ben,

Well, would you believe that your question about server side caching made me think twice about all the steps I already tried. I went back into BB cache, WP Super Cache, CloudFlare, and MaxCDN. When I looked in MaxCDN, I saw BB layouts in the cache. I purged them and presto - we are good to go!

I must have cleared BB cache last previously so the MaxCDN cache had added the files again. I’m not sure but it looks like it is functioning as it should be at this point.

I put CloudFlare in dev mode while making updates. Do you guys suggest that I put the CDN on pause as well or no?

Also, how would I figure out if server side caching is on - just ask my host?

Thank you so much!

Hi Julie,

To find out about server side caching, you will need to speak to your host.

For the CDN, I would always disable/pause anything like a CDN, caching when working on the site, to prevent any issues. Once I’m finished enable them again.

Hope this helps!


Hi Danny,

Thanks so much for your reply. I appreciate it!


Hi Julie,

No problem, I was happy to help!


Your support really is great! Thank you!