Comment Form Showing Even with Comments Turned Off

You can see the page here:

The comment form is still showing on the site even though I have the boxes unchecked for that page. Any ideas?

Oh, and it’s only the home page, check this one out:

I figured out that it is the shortcode of the recipe causing it. When I take that out, it goes away. I’ll reach out to the shortcode people.

Interesting. That’s an odd bug. As a temporary fix, you can always hide the comment form with CSS:

.fl-comments {
  display: none;

Hey David,

More to what Robby said, if you’d like to get rid of the comments section on ALL pages, you can use the plugin Disable Comments. :slight_smile: