Cornerstone conflict


I have been using BB with X theme including their Front end builder, cornerstone, with no real problems for a while now. Of course, I always know which page uses BB vs which uses cornerstone. But I forgot to tell a client who went ahead and started using BB in a CS page. SO now the page is getting it’s knickers in a knot!

My question is: can I somehow remove the BB mark-up from that page only? As the cornerstone plugin will no longer work on that page unless I disable Beaver builder.

An additional but related question: after removing all the padding and margins from any row (and content within row) options, it seems to still actually enforce some padding. How do I get control over that extra space between elements?

Hey Seamus,

How does the CS page builder work? Can you try reverting the page to an earlier time and see if that takes care of it? You could also try switching it back to the Text Editor, that should remove any BB styling from it.

Do you mind sharing the URL of the page in question so we can take a look?


Hi Ben,

Cornerstone is basically’s front end builder. It’s pretty good, but I like to use both and up until now have had no problems.

I am now not sure if the client did use BB on the page. They say they didn’t but… I am suspicious, perhaps they clicked it and that was enough, don’t know :slight_smile:

Anyway, I had to resolve the problem by editing the cornerstone mark up in the BB text editor because CS has completely pooped itself on that page. Which is fine for me but not ideal for client.

I guess going forward I may need to choose one or the other per project, however, using both would be better.

Here’s the URL, the home page is the only one utilising Cornerstone (and revolution slider plugin), all the others use BB.

As you can see there is still a gap between the hero shot and the first block of white text on grey which I will like to close, but I just can’t seem to the find the style to tweak.

Love your work!

Hey Seamus,

Do you not have revisions enabled on your site? It should have been able to fix the issue for you. But I’m glad you figured it out! :slight_smile:

Re the extra spacing, that is actually coming from your theme and your custom HTML. Take a look at the screenshot below for reference, your theme is adding a top margin on the content area.

You could try using the CSS snippet below and see if it works.

.site .x-container.offset {
  margin-top: 0px;

There’s also a rouge p tag on your custom HTML that is causing an extra space as well. Take a look at the screenshot below for reference. You’ll need to remove that p tag to completely remove the extra spacing.

Hope this helps! :slight_smile:


Thanks Ben that css did do the trick! :slight_smile:

In the end, I was able to make Cornerstone work again on that one page by (duh) turning Beaver Builder off on that page! How to do so was not immediately obvious but I eventually stumbled on it (click text tab in WordPress page editor view). So it seems I can happily resume mixing and matching the two front end editors as long as we know which one to use per page.

As for the rogue paragraph tags, these seem to be introduced by cornerstone but I can live with them.

Thanks again for the bodacious support, appreciate it.

No worries, Seamus! And glad I could help! Enjoy BB! :slight_smile: