Edit mode not loading - can't edit any pages

Yes, I know, several people having the same problem, but I haven’t seen anyone posting a solution, so I want to put extra focus on this. I’m using Beaver Builder lite because it came required for WPZOOM’s Inspiro theme, so I can’t create a support ticket.

I created all pages 6 months ago, and everything was great, and now I can’t edit anything on any page at all. When I click “open in beaver builder”, it’s just the page that loads, as a visitor would see it – there’s no editor interface for me.

I have tried everything mentioned here:


And here:

Thanks,
/Jonas

Did you follow the troubleshooting steps?

Thanks for replying! Yes, I disabled all the plugins – no effect.
I flushed the cache, and tried in Mozilla and Firefox on two different computers.

Thanks,
/Jonas

Is there a JS error in the browser console?

I don’t know… maybe? This is what there is:
[Exception… “Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIContentSniffer.getMIMETypeFromContent]” nsresult: “0x80040111 (NS_ERROR_NOT_AVAILABLE)” location: “JS frame :: resource:///modules/FaviconLoader.jsm :: onStopRequest :: line 295” data: no] FaviconLoader.jsm:295:24
Content Security Policy: Ignoring “‘unsafe-inline’” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “https:” within script-src: ‘strict-dynamic’ specified
Content Security Policy: Ignoring “http:” within script-src: ‘strict-dynamic’ specified

Nothing relevant there… is this shared hosting? Perhaps you are running out of memory. Have you checked your hosts error logs?

1 Like

Unknown territory for me, I don’t really know about that. I doubt I’m running out of memory, it’s literally the same site I created six months ago, and there’s not a lot of data.

It’s on one.com. They can’t help because Beaver is 3rd party

Ah one.com the vital clue.

Your webhost, One.com adds an htaccess file in the WP uploads directory that prevents any of our JS from loading.

The code looks like this:

# Block javascript except for visualcomposer (VC) plugin
RewriteEngine On
RewriteCond %{REQUEST_URI} !^.*wp-content/uploads/visualcomposer-assets/.*\.js$
RewriteRule ^(.*\.js)$ - [F,L]

That would need to be modified to allow our files to load as well or removed completely from the .htaccess file. Since One.com is the one that puts it there, they would be the best people to reach out to for assistance if you’re not sure how to edit the .htaccess file.

I talked to one .com, and they know nothing of that special code. My htaccess looks like this:


# BEGIN WordPress
# The directives (lines) between `BEGIN WordPress` and `END WordPress` are
# dynamically generated, and should only be modified via WordPress filters.
# Any changes to the directives between these markers will be overwritten.
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Thanks,
/Jonas

There’s this little dot here… does that mean anything?

In the uploads folder, not the main htaccess file, they add another one in the uploads folder.

OK, thanks.

In the meantime, I reinstalled everything, and it’s working now.

Thanks,
/Jonas

OK, I found the precise error.

Version 2.2.4.3 works fine.

If I follow the update recommendation and update to 2.3.1.1, it stops working and I can’t edit anything.

Thanks,
/Jonas

OK, that’s NOT the precise error… looks like some cross reffed version incompatibility. Because now it doesn’t work again. I’ll write again when I have something more accurate.

Have the JS console open the whole time… there will be a JS error at some point