Error updating plugin

I am getting the following error when trying to update the plugin:

An error occurred while updating Beaver Builder Plugin (Agency Version): Could not copy file. bb-plugin/includes/vendor/campaign-monitor/csrest_administrators.php

Any idea what could be the cause?


Hey Nigel,

Do you have your license key active in the page builder settings by chance? Figure we would go through the obvious first, but if so, go ahead and shoot over super admin access and I can take a look.



Yes, the license key is there and is active.

I can’t provide admin access unsupervised (way too many security related issues). But I can bring you in directly to the desktop of the server via teamviewer or gotomeeting or any other webmeeting software of your choice. If that works for you just let me know a date/time and I’ll set it up.


Hey Nigel. Thanks for that. What kind of server are you guys running on? Also, where is the server hosted? Have you had issues updating any other plugins? Something on the server is preventing our script from removing/modifying that file. It’s unlikely, but are you guys possibly running low on disk space? Lastly, do you get the exact same error message every time you update?

If you can let me know some more of the details, we’ll gladly try to figure out what’s going on. Also, you might want to open a ticket with your hosting company (if that’s possible). They might have some insight that’s specific to their servers.

As a temporary solution, you can always manually update the plugin by removing the old version and uploading the new version.


Running on a Windows Machine under IIS 8.5. This server a dedicated server (not shared with anyone else).

We haven’t tried running any other updates. Well, unless you count the BB theme which updated just fine.

A full 1 TB of diskspace is available.

Yes, so far it’s been the same message.

Since this isn’t a security update, I can spend some time trying to work and fix the underlying issue before giving up and manually uploading the files - as long as you’re willing to troubleshoot as well.


Thanks for the info, Nigel. I am not too familiar with IIS servers, but this sounds like a permissions issue. I tried doing this google search, “Could not copy file iis” and it turns up some good results on the issue. You might try browsing through some of the results from that search and see if any of the suggestions apply to your setup. I’ll keep looking for a better answer. Let us know if you make any progress. Also, I’d be curious to see if you have issues updating any other plugins.

Hi Robby:

I thought it was a permissions issue too but I’ve been able to add new plugins.

I tried updating again and this time it said the update was fine. BUT, the version number never in the plugins screen never changed - even after a refresh and logout/login cycle. I guess the original update succeeded partially and when it ran into the error WP never reversed the changes. Since I wasn’t sure what state the plugin was in at that point, I wiped the folder and installed the new version manually.

It looks like you have a new version in beta so when that comes out I’ll see how the upgrade goes then and I’ll let you know if anything goes amiss with that.

I’ll also let you know the results of any new updates for other plugins when that happens.

That sounds like a good plan. Definitely let us know how the next update goes.