Expected rbracket background-image: url([wpbb post:featured_image size ='full' display='url']);

Trying to make a custom post layout(BB Post module). It seems that the syntax is not accepted with this line:
background-image: url([wpbb post:featured_image size =‘full’ display=‘url’]);
screenshot 1 is the error: https://i.imgur.com/LN9llxa.png
Screenshot two shows that the shortcode work OK if just in a div: https://i.imgur.com/Gm5te7N.png

col 37 is the colon within the shortcode. I thought perhaps I need to escape it with a \ or something.

Expected ()
Then I considered that the url part of the line needed to be in double quotes. does not seem so either. frig this form won’t let me put more than one link per post. I’m sure that you can figure out this url:/FEMUrBr.png
I tried escape quotes, colons, equals signs. None seemed to work.
Thanks for any help. BB is up to date, etc.

Turns out that you can put the background-image inline with the html. Probably this is OK for what I am aiming to achieve. Although I was hoping to have some custom fields with things like post feature color also in the css file.
this works:

this is the cwhfeaturesblock2 [wpbb post:featured_image size ='full' display='url']

Shortcodes will work in css, if you enable it. The error you are seeing there is the code tool … its not going to know your shortcode will output a url, just click save and ignore the error.

“if you enable it.”
I’ve looked for a setting ‘enable shortcodes in css’ or something similar. Didn’t find anything.

Have tried the following lines:
background-image: url([wpbb post:featured_image size =‘full’ display=‘url’]);
background-image: url("[wpbb post:featured_image size =‘full’ display=‘url’]");
I did try to exchange double quotes for singles, singles for doubles, escapes .
None seem to be correct.

The below code renders out like this: https://i.imgur.com/ezn0vb9.png

this is the cwhfeaturesblock66 [wpbb post:featured_image size ='full' display='url']

height: 250px;
width: 250px;
background-size: cover;
background-position: center;
background-image: url([wpbb post:featured_image size =‘full’ display=‘url’]);
background-repeat: no-repeat;

There isnt a setting, you have to manually enable it