Font-Awesome icons not showing

Hi support,

I’ve created a global header with two buttons, both buttons have a font-awesome icon but both icons don’t show up.

Some more info:

  • I’m using the BB-theme child theme for this project
  • I tried using the main BB theme
  • I tried disabling all the plugins
  • Updated BB plugin & BB theme to the latest version
  • tested on my local and preview development environment

In my next post I’ll provide you with the URL and login so you can take a look for yourself.

[Content Hidden]

Hey Twanneman,

I took a quick look and you seem to be still using BB 1.7.5. Can you try updating that to the latest version of 1.7.6; we’ve made specific changes involving fontawesome.


I’ve updated both the theme and the plugin but the problem persists.

Hey Twanneman,

Sorry to hear about that! Took another close look and it appears that the cause of the issue is this CSS code below that you’ve added in Layout Settings > CSS.

.fl-builder-content a.fl-button *, .fl-builder-content a.fl-button:visited * {
    font-family: Montserrat;

If you want to change the anchor tag’s font then you may do so by using the following code.

.fl-builder-content a.fl-button, .fl-builder-content a.fl-button:visited {
    font-family: Montserrat;

I just removed the wildcards.


Hi Jun,

You’re right! Sorry I looked over that and it solved the problem :slight_smile:

Kind regards,


Hey Twan,

We’re using Fontawesome for our icons so your code overwrote Fontawesome as the font-family because of the wildcard. Glad to hear it’s all sorted out now and thanks for taking the time to let us know. We appreciate it!

Have a nice day!