FontAwesome Issues In Firefox

In Firefox (not Chrome), I’m getting the following error message i the developer console:

downloadable font: download failed (font-family: “FontAwesome” style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed

The icon is not displaying correctly on the screen, confirming that this is actually a true error and not just something being reported as an error.

It appears that this is a known issue but that there’s a workaround.

[Content Hidden]

Hey Lloyd! Sorry you’re having trouble. I am not seeing this error message on my end. Is it happening on a particular page? What version of Firefox are your running? Is it the current version? We’ll do our best to figure out what’s going on here. We just need a bit more info. Thanks! :slight_smile:

[Content Hidden]

Okay! I think I see what’s going on.

For some reason, on the Mac version of Firefox it’s automatically redirecting my to the https version of your site, but on Windows it’s not.

The issue is only happening when you’re on the non-ssl version of the site because the fonts are loading from the https URL that’s set in your general WordPress settings. You’re going to want to ensure that all of your pages are redirected to the https version of the site. That should solve the issue.

What webserver are you using? Assuming it’s apache, you’ll probably be able to do a Google search and find a line to put in your .htaccess file that will accomplish this.

Good catch. Interesting that I actually have an htaccess redirect for https that is respected in Chrome but not FF.

That’s odd. I am a bit leery to offer too much help here as I am not a server expert, but if you can send me the redirect code, I’d be happy to at least take a look…