Image Size Reverts - Version

If you edit a BB Widget that has an image attached to it, it doesn’t persist the same photo size selection, but defaults back to the thumbnail. Here are two screnshots of widgets that reverted to thumbnails just now.

Hey Tom,

I just tried this on my local install and on a dev server that we have and it works just fine. The size sticks no matter what I chose. Do you think you could share temp admin access to your site as well as steps on how to recreate it so we can check?


Hey Ben,

If it’s not doing it for you, then I wouldn’t worry about it. If I run across a similar error again, I’ll let you know. It’s hard for me to share the login because this is on my local machine.


Hey Tom,

No worries! One thing I could think of that might be causing this is caching. If you have any 3rd party caching plugins try disabling them while building the site. Let us know if you find/need anything further! :slight_smile:


This is just the thread is was looking for. I have had this experience on two websites in recent days. Both using a Content Slider. When I open the slider to, say, make a text adjustment, all of the images, even when there has been no ‘edit slide’ action, drops back to Thumbnail. It seems that this only happens once, on future visits the image is the selected size.

I have just discovered on one site that every image that is inside a Beaver Builder photo module, the image has reverted to Thumbnail. On the blog page, the images are as they should be but on the individual posts, where a BB Module has been used, no image.

Hey John,

Have you recently migrated the site? The only time I was able to experience this was with another user who migrated the site to another domain. The migration wasn’t done properly causing the problem.

Or could you be using custom image sizes? That would be the only thing I could think of that would cause this problem. Have you fixed the problem already? If not, do you mind sharing the URL of the site so we can take a look?


I am experiencing this same issue with the Callout module. The site is hosted on Siteground and was created using their Staging tools.

I’m also seeing this on multiple sites hosted with WP Engine. It seems very intermittent, possibly a caching issue. I think the original image I chose is still displaying as the original uploaded image, but when I go back in and edit a page with the image, the image size selection shows as the thumbnail size.
I’ve seen this on photos set in Columns, Rows, and Photos.

Hey Daniel,

Like what Doug said, this could be caching issue. Do you have any caching plugins installed? Try clearing its cache as well as BB’s cache. It’s also possible your hosting offers some kind of caching as well. We can take a look further if you want but we’ll need temp admin access to the site. I’d suggest creating a new thread so you can post details via private reply. :slight_smile: