Inserting a slider crashed the Edit ability of the page..


I’m helping someone with their site. They inserted a slider in a page, same as usual, but the page ends up being uneditable.

I’ve cleared the BB cache, and reinstalled a fresh version of the plugin, no luck…

The errors gotten when trying to edit are:

Fatal error: Uncaught exception 'FLJSMinException' with message 'Unterminated string literal.' in /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-jsmin.php:96 Stack trace: #0 /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-jsmin.php(237): FLJSMin->action(1) #1 /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-jsmin.php(66): FLJSMin->min() #2 /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-builder.php(1930): FLJSMin::minify('(function($){\n\n…') #3 /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-builder.php(378): FLBuilder::render_js() #4 /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-builder.php(307): FLBuilder::enqueue_layout_styles_scripts(1170) #5 [internal function]: FLBuilder::layout_styles_scripts('') #6 /home/charle93/public_html/headway/wp-includes/plugin.php(496): call_user_func_array('FLBuilder::layo…', Array) #7 / in /home/charle93/public_html/headway/wp-content/plugins/bb-plugin/classes/class-fl-jsmin.php on line 96

The theme used is Beaver Builder as well.

There used to be a Headway site in that folder, which is why you’ll see it in the paths.

Hello Nomad411,

Sorry to hear about this issue. Have you tried the plugin deactivation route, i.e., deactivating all of the plugins except BB then see if the problem is still there. If the problem is gone, reactivate the plugins one by one until the problem reoccurs to find the 3rd party plugin causing the issue. If the problem still occurs after deactivating all the plugins, we might need temporary admin access to the site to dig in further.

Hope this helps!


I did yes, no luck.

I’ll create you an admin login and post it privately in my next post.


[Content Hidden]

[Content Hidden]

Hey Nomad411,

I’ve restored the page to an earlier revision and is now editable. Maybe you can have your client reinsert the slider and see if the same problem happens? I tried creating a test page and inserted a content slider and a slideshow and it works fine. If possible, try to ask what slider module is used, as well as what images, properties, etc. Or if another slider is used since I can see 2 other slider plugins installed.


Thanks Ben,

I’m glad to hear that there’s nothing major wrong.

I’ll definitely ask himm to redo what he did and watch.


No problem! If you could get back to us regarding how it went we’d greatly appreciate it! :slight_smile: