Install error message - says plugin exceeds max filesize directive


I’m installing standard Beaver Builder on a localhost site to use with Genesis and Dynamik. When I try to to install the BB plugin zip file it returns this message:

The uploaded file exceeds the upload_max_filesize directive in php.ini.

There are no other plugins activated. This happens whether Dynamik or just Genesis is the active them. Have searched the forum but not seen a similar issue.

Thanks for any help.

Hi Irene,

It sounds like the beaver builder .zip file is larger than your upload limit. There are two ways to get around this. First, you could manually move the .zip file into your plugins folder and unzip it, i.e., skip the WordPress plugin upload and just do it yourself.

Or, you can increase the maximum upload size by editing your php.ini file and restarting your local server. Are you using MAMP, XAMPP or another? If you do some Googling about “increasing upload_max_filesize” you should find a good tutorial pretty easily; it’s a common problem. Let me know if that helps!

Hi, that worked, thanks for the help!

Awesome! My pleasure!

Thanks for the previous posts. I also ran in to this error message when I tried to upload BeaverBuilder Pro to my wordpress site.
I went with option 1;

manually move the .zip file into your plugins folder and unzip

It was quite simple and it worked.

Thanks for your posts.