Issue with Escaped Characters in CSS Code editor of Beaver Builder Child Theme

I am using Beaver Builder Child Theme current release version (v1.4) along with the release version of Beaver Builder Pro plugin.

Beaver Builder Child Theme > Customize > Code > CSS Code

In the CSS Code editor of the Beaver Builder Child Theme I am attempting to use escaped characters but unfortunately they are being interpreted literally.

This is the code I am using:
q .attribution:before {
content: ‘\2014 \00A0’;

You can see the effect of this at this image:

Looking in the database, it appears the CSS is stored like this:

A work around is to escape the escape character, like this:

Looked through the forum and the documentation but could not find anything related to this issue.

Hey Justin,

Welcome to the BB forums! :slight_smile:

That is actually a bug with core, they tend to strip out backslashes. You can either place your CSS on your style.css file, or on the page builder side under Tools > Global Settings > CSS. Or if you want that CSS to only appear on one page, you can place it under Tools > Layouts Settings > CSS.

Hope this helps!


Valid point. Sorry to have bothered you about it. It’s been a (exceptionally long) while since I made use of a WordPress edit box for entering CSS or code, the likelihood of using a backslash in regular written prose is small, and now that you mention it, it is a “Duh!” moment of recollection of the problem.

Thanks for the prompt follow-up.

Hi Justin,

Happy to hear your issue has been resolved and thank you for informing us. We appreciate it.