Kleo Column Problems - Columns will not go full width after adding code below

For some reason, my system is taxed as well while running this site.

.fl-builder #main-container.container {
max-width: 100% !important;
width: 2880px;
margin: 0px !important;
padding: 0px !important;
.fl-row-bg-video .fl-bg-video video {
bottom: 0;
left: 0px;
position: absolute;
right: 0;
top: 0px;
width: 100% !important;
height: auto !important;
.fl-builder .wrap-content {
margin-top: -40px;
.fl-row-fixed-width {
max-width: 2880px;

This is the code. While it did fix the fullwidth problems. It only did so for the rows. But not the columns. I’m trying to figure out how to fix that. Any ideas.

I also manually set all padding to 0

Thanks! PS…thanks for the awesome support!!!

oh here is the trial page I’m working on:


Hey Jeremiah,

Columns aren’t meant necessarily meant to go full width, but rows are so you actually have the correct code inserted. A column requires a row anyway so just set the row to be full width and content to be full width (also in row settings) and anything you insert into it in the way of modules/columns will be able to span the full width row.


Yes. I’ve done that before. And it’s worked on different themes. However, for some reason that is not the case in this theme.

Sorry Jeremiah, I’m not quite sure I’m following. I looked at the example and it looks like it should with full width rows?

Just for clarity. On the link I posted. I made sure that both were checked.



but as you can see. The columns still have a space and seem to overlap rows above (which could fixed with padding I’m sure). But I can’t seem to make them go fullwidth even when the settings are checked.

Make sure you zero out both the row padding as well as column padding. Zeroing out row padding gives you the full width when using a background image for example, but columns also have a default 20px padding on each side. Modules do as well so there are technically 3 sets of padding to take a look at depending on your application.

Ok. So my slider posted on other pages span the entire row. Here they do not. On other pages, my pics span fullwidth, even when placed in colums set to fullwidth. Container - fullwidth.

Here they do not. So the question is, what setting am I messing up. Or is this a conflict it may be having with the current theme I’m working on. When I used this alongside X-theme. It worked GREAT.

Excellent! I could have sworn I had did that. But I guess not. Worked like a charm!