Page Builder not working

Hey gang, first off, thanks for the great support via email for my weird account issue.

Now that I have the plugin installed, the Page Builder doesn’t work. Everything appears to function normally but when I drag an item (row or other element) to then drop it to the the page, nothing happens. I have deactivated all of the plugins and it still happens. Oddly, the drag & drop will work when editing a Post but not when editing a Page. Any ideas?

Here are some of the vital stats:
WordPress 4.3.1
KOEL child theme for Layers
Host: WP Engine

Let me know if there’s anything else you need to help. Thanks!

Hey Aaron,

Welcome to the BB forums! :slight_smile:

This maybe caused by the theme you’re using. Could you try switching to a different theme real quick and see if you get the same problem? You can try one of those free Twenty-X themes. Let us now how it goes!


Changed to the Twenty Fifteen theme & it does appear to be related to the theme. The Page Builder works as designed, however there is a big sidebar w/ title on the left, changing the layout/viewport of the page so it’s not ideal to work with. (I have a screenshot if it helps.)

Any ideas on what’s up with the theme?

EDIT: It appears to be related to the Layers base theme as the Page Builder doesn’t work there as well.

Appreciate the help!

Hey Aaron,

That sidebar is how the theme works. Regarding your KOEL theme, do you mind sending us a copy so we can play around with it on our local dev? You can send it to themes [at] fastlinemedia [dot] com.


Just sent…

Hey Aaron,

Just tried playing around with your theme and it works just fine on my local dev. Can you share temp admin access to your site so we can check? You can use the private reply option below.


[Content Hidden]

Hi Aaron,

I did some digging and it looks like the issue is that Layers doesn’t call WordPress’ standard the_content function if there isn’t anything in the default editor.

That is quite bizarre as almost every theme I have ever seen calls the_content without checking if ( '' != get_the_content() ) first. You can see that happening on line 36 in themes/layerswp/partials/content-single.php.

Because they are doing that, we aren’t able to hook into the content filter and display the necessary code for Beaver Builder to work.

There is a workaround, however. When creating a new page, just add some content to the editor first (such as the word “test”) and save a draft or publish before launching the builder. Doing that will trick Layers into calling the_content.

You may also bring this issue up with them as I can see it affecting other plugins. We’re not the only ones tapping into the_content, many plugins do that and expect it to be called to work.

I hope that helps!


Hi Justin, thanks for the fix! I tried it out and your solution worked. It is an odd workaround but it now functions as designed.

Thanks again!

Hey Aaron,

Great! Sorry you have to use the workaround. If you contact them, you might be able to get them to change what they’re doing. It’s definitely not something you see often in themes.