Plugin update from 1.3.3 to 1.3.3.1 fails

Our site is currently on WP 5.5, and shows an update available for the Beaver Themer plugin. Attempting to install the update fails:

An error occurred while updating Beaver Themer: Update package not available.

Anyone know what’s going on?