Recentering thumbnails

I tried looking for an answer to this but it seems people just want to make thumbnails bigger instead of what I am trying to do.

The auto-generated thumbnails are set in a way that they sometimes crop important elements of the image. I went into the Media Gallery and recentered the thumbnails that needed it. It seems to have saved but will not show in the thumbnails showing in the gallery much less on my site.

I am not sure regenerating my thumbnails would help as I understand it will just regenerate them overwriting my modifications. Right?

Thanks for your help!

Hey Javi,

Thanks for getting in touch! You can control the Thumbnail’s size by going to Settings > Media. Specify the width and height and if you don’t want to hard crop, uncheck Crop thumbnail to exact dimensions. Then you can run regenerate thumbnails to apply the new settings.


Hey Jun,

Thanks for the speedy reply.

I actually do no want to change the size but recenter them so they show the subject of the image properly.

As an example, see this screenshot ( See on the left, I have recentered it so that the person’s head is visible but on my library and anywhere else it still shows the one with the cropped head that was generated automatically. I only see the correct crop when I go into Media Library and edit the photo. This confirms it was saved, but for some reason it’s not updating anywhere else.

Hey Javi,

Have you tried running the Regenerate Thumbnails plugin that Jun mentioned above? Basically, what’s happening is that when you uploaded the image, WP immediately created a thumbnail sized image, and that’s what you’re seeing right now, where the head is cropped. When you run the plugin above, it re-generates those images now based on the modification you have made.

Give it a shot and let us know how it goes! :slight_smile:


Thanks, Ben.

I had tried that initially but it just regenerated them as before (as in: overwrote my modifications).

I just uploaded correctly cropped images to the media library instead.

Gotcha! That works too! And thanks for taking the time to inform us.