Reliable way to disable smooth scroll, or fix scroll offset when linking to hashed linked from an external site?

I have a mostly single-page website: Boston Sings [BOSS] A Cappella Festival | CASA Events

I have several anchor links on my main nav that link to sections on the home page. Smooth scrolling was really messing up where the scroll end positions would be, so I’ve given all my anchored sections fl-no-scroll classes. This fixed the scroll issues when clicking through to anchors from the nav.

The problem I’m having is that I still see smooth scrolling (and, therefore, scrolling too far) happening when I go directly to a hashed link or click through from another page/site. Is there any way to turn off smooth scrolling for that context? I’ve tried using the tweaks from the BB KB but they have not been working well or consistently.