Responsive editing goes haywire

I’m having a weird issue for which I can’t find any online clues to what may be the cause.

To start, the website exists out of Wordpress (duh-uh) with Astra as theme, and Beaver Builder Lite, Ultimate Addons for Beaver Builder and Astra Pro as plug-ins. Everything is up to date and it’s a fresh site I’m working on.

Now I’m going to try, really really hard, to describe the problem:
It happens when I get to responsive editing. I have placed my rows and content and then go to the tablet/medium-size. I set everything the way I want and all looks fine. I go to cellphone/small-size and set everything up. Everything looks great, but when I go back to tablet/medium my screen has become a jumbled mess for some unknown reason. It looks like the setting from small have taken priority over the medium ones, even though in the editor all my settings are as I have set them. The settings for small influence all higher up levels.

I’ve cleared the cache on all levels that I could find (inside WordPress, Beaver Builder, and the browser) and it didn’t resolve it. I changed browsers and the problem remains. I deleted everything and started again and, well, the same result. When searching online none of the issues about responsive editing are even remotely similar.

Help please? Pretty pretty please?

I was trying to work around the issue temporarily by making a row that is only available on large and medium devices and checked the preview I noticed that nothing showed up for the medium preview. So I thought about the fact that I changed the settings for my breakpoints in the beaver builder general settings from the default 992px to 1150px for medium and 768px to 780px for small. I changed them back and the issue was gone. I then slowly upped it back from 992px to 1150px and everything was ok. Then I changed the small setting to 780px and everything was broken again.

So my problem is solved as I can live with the 768px instead of 780px for small, but this does seem like a bug to me. Does anyone have an idea why this is happening?