Skip To Content Link Always Showing on Mobile Pages

For some reason, the accessibility “Skip to Content” link is always showing when people are viewing my site. I’ve confirmed this by using a user session recording program.

The font changes as well when that link shows up at the top. Personally, I do not see any of that when I’m logged in and editing the page with Beaver Builder.

Here’s an example page: https://adamhagerman.com/share-expenses-living-together/

Here’s what they see:

Does anyone know what on earth could be going on? Did I accidentally delete some code somewhere?

Here’s what they SHOULD see:

Looks like the 1st screenshot is viewing a stale cached version of the page. How many caches are you using?

So, I found a thread in the Facebook group after I posted this (I wasn’t accepted in the group yet).

I’m using WP Rocket with Cloudfare on as well. I think it was the minify CSS setting that jacked up the page. I turned it off and cleared the cache which seems to have fixed the issue. I’m going to turn things back on one by one to find the culprit.

Thanks for replying!