Triggers automatic failure notice when activating

Just downloaded the Alpha release to test on my testing site, and when I clicked to activate the installed plugin it gave me this:

Plugin could not be activated because it triggered a fatal error.

Parse error: syntax error, unexpected '[' in /home/fresyfis/public_html/htbeta/wp-content/plugins/bb-plugin/extensions/fl-builder-template-data-exporter/classes/class-fl-builder-template-data-exporter.php on line 246

Not sure what’s causing the error itself.


Thanks for testing and the report! I believe I know what the issue is, but for future reference, is it possible to tell me what server OS and PHP version you are on?

I’ll get this fixed and into the next alpha release.


I just pushed out 1.8-alpha.4 that should fix this issue. Give that a shot and let me know if it persists.


It says I am using PHP 5.3 via my host and OS for the server is: Cloud Linux

Thanks, Sasha-Shae!

Oh, just tried the newly released 1.8-alpha.4 and now I get this when I click activate:

Parse error: syntax error, unexpected '[' in /home/fresyfis/public_html/htbeta/wp-content/plugins/bb-plugin/includes/updater/classes/class-fl-updater.php on line 115

Also, my host for that particular domain I’m testing it on said my site is using PHP 5.3 and the OS is Cloud Linux

Ah, shoot. Ok, it looks like we have that error in more than one spot. I’ll do a search and see if it’s anywhere else and push out an update. Thanks for testing.

Sorry I couldn’t chime in sooner. Justin, I removed the [0] from both of those errors that Sasha mentioned and was then able to activate the plugin on my fresh multisite install (php 5.3xsomething, sorry can’t remember).

I would continue to get a few errors with the front end customizer class or module here and there but I was usually able to continue editing and save changes. Sorry I didn’t document the exact errors. Whenever I refreshed or pressed save they would just go away. I’m a terrible alpha tester I just realized :slight_smile:

Thanks, Jeffery! I just switched to 5.3 on my dev install and am fixing this now. I appreciate the help!

Hi Sasha-Shae and Jeffery,

I just updated the 1.8-alpha.4 zip with the fix for this as well. I believe that should do it.

Thanks again for your help!


Awesome!! The latest fix worked :slight_smile: yay!

Great to hear! Let us know if anything else comes up and enjoy!