Typography issues

I just upgraded to BB Pro and BB Theme. I’m have issues with the Typography controls in Customize. Whenever I attempt to edit a default (say H1), I can see the changes relating to font family, size, and positioning, but font color doesn’t seem to want to work. Aaaand when I hit “Save & Publish”, all my changes go away.

I was having the same issues using the theme typography controls until I clicked the “Force Styles Override” in the Easy Google Fonts setting.

This is the site I’m working on: http://cpanel3.neonova.net/~wwwrestinglion/
Using Safari 9.01 on OSX 10.11.1

Any ideas would be helpful!
Thanks, John

Hey John,

Thanks for getting in touch! It sounds like a caching problem. Do you have a caching plugin installed? Try clearing its cache or if you have server side caching, clear it as well.

Our theme should support Google Fonts by default. Try disabling that Easy Google Fonts plugin as well and see if that fixes the issue. Let us know how it goes!


Hi Ben,
Thanks for your reply. I disabled Easy Google Fonts and that seemed to clear up the problem. Although, now I don’t have the ability to create custom theme-based font styles like I did when using EGF. Is there a way to do this in BB Theme?

Also, being somewhat new to WP in general, why would I want to use a caching plugin? And how would I know if I’m using server-side caching and then how would I clear it? (Sorry for the newbie questions…)

Thanks, John

Hey John,

Just wanted to chime in here. Check out some of these recommended plugins that could actually improve your Website in terms of speed, caching, SEO and etc.

Hope this helps!


Hey John,

I can see your site is using the BB theme which supports Google Fonts by default. What do you mean when you say custom theme-based font styles? Could you elaborate? How are you doing this with the EGF plugin?

I’m not really an expert when it comes to hosting but some sites I’ve ran into have a Flush Cache button at the top wp-admin bar. This allows them to clear the server side caching they have enabled. That’s my cue if they have server side caching. I guess the only real way to check is if you get in touch with your hosting company and ask them.