Unable to edit pages. Console gives JS error


I’m having a problem with my site where I try to edit the pages and when I open a page in the page builder menu everything displays as expected, but nothing is clickable and I get the error "Uncaught TypeError: Cannot read property ‘interval’ of undefined " in the JS console.

This error is in the private _lockPost function in line 55 of fl-builder.js: wp.heartbeat.interval(30);

It worked perfectly well before - I’m not sure what’s causing this. It’s occurred seemingly randomly on another installation as well. It seems that perhaps the heartbeat javascript is not being loaded? Any ideas?

Hmmm, that is interesting. Would you mind sharing the links to the sites where you are experiencing this? We’ll look into that as soon as we can!


We have the issue on http://insted.wpengine.com/, do you want login credentials?

I also tried on another install with disabling all plugins and using twenty ten as the theme and get the same issue. Maybe it is connected to WP Engine as the hosting provider that we use?

Thanks for your help



We had the same problem with WP Engine as they recently disable the heartbeat feature for non admin page.
After submitting the issue to WP Engine support they released a little plugin to install in the mu-plugins directory where you have to configure exceptions where heartbeat should be activated outside the admin. So just ask them to give you access to this plugin, install it in your mu-plugins directory and configure an exception for “index.php” and Fastline Page Builder will work again…

Hope this help.



Thanks Nicolas

I opened a ticket with wpengine at the same time and will now provide your information to that ticket with them.

Thanks again!


Hi Nicolas,

Thanks for helping out with this. Much appreciated!