WordPress Front-end Editor Plugin disables BB text-editor


Since BB doesn’t edit post on the front-end, I’d like to use the WordPress Front-end Editor to do that. When I have the plugin activated, it disables the BB text-editor on page builder pages. Once I disable the plugin the BB text-editor works fine. Is this something you can help out with?


Hi Helms! Thanks for reaching out with your question. We’ll look into this. We have had some trouble with plugins that modify the default WordPress editor, and we’ve also had troubles with other front-end builders. Unfortunately, the WordPress Front-end Editor hits both of those trouble points. This may take us some time to work out, but we’ll definitely look into this in more detail and see if there’s someway we can prevent the conflict. Thanks for bringing the issue to our attention.

Thanks for looking into it Robby. I’ll look out for your reply.

Hi Helms. I did some testing this morning and, sure enough, there is a conflict using the two tools together.

Because the Front End Editor is still a beta feature plugin, I don’t think we’re going to be able to dedicate too much time into fixing this conflict until the plugin gets closer to an alpha release. But, I did find this support topic that goes into some detail on how to disable the front end editor from certain posts and pages:


While this isn’t ideal, this is probably going to be the best way to use both plugins. You’ll want to disable the front end editor on any pages/posts that you plan to use Beaver Builder on.

I hope this solution works for you. Let me know if you don’t think it will. We’ll keep an eye on the front end editor and cross our fingers that the issue gets resolved as the development gets closer to a final release.


Hey Robby. Appreciate you looking into it quickly. One problem though, the link you just posted is the wrong plugin. I haven’t tried that plugin and don’t know if the problem is similar or not. Here’s the correct plugin: WordPress Front-End Editor

This version is in beta already. If you have time, check out the plugin.

Thanks again.

Oh no! Sorry about that. The plugin you linked is the same one I was testing, but I guess the support topic I found was for a different front end editor.

My answer is still similar, unfortunately not as easy now. You’ll probably want to look into disabling the front end editor for pages that you’ll be using Beaver Builder on. You could reach out to the developers of that plugin or perhaps ask in the WordPress IRC channel or other WP Community message board/chat. I am afraid I won’t be able to help much more than that. Sorry again.

No problem Robby. I’ll reach out to the developer and see what he/she says. If I’m able to get a solution, I’ll post it back here for your info.

Thanks again.

Sounds good! Do let me know. Thanks Helms.