Plugin not pulling core templates on subsites, only on main site

I am running an Agency version of the beaver Builder on wordpress multisite. It works great on the main site but it breaks on the subsites. I have enabled the “View All Templates” on the network settings, reinstalled both the plugin and theme, running the latest version of wordpress mu and plugin and nothing seems to solve my problem. Please advise asap as I am on a deadline crush. Thank you !!!

I cloned the main site to see if that made a difference and nothing … here’s a link to main and subsite. both are excatly the same but subsite breaks

Hey Carlos,

Thanks for getting in touch and welcome to the BB forums! Your subsite seems to be getting data from what I would assume an incorrect directory? Do you have anything special setup on this subsite? I will make a separate private post regarding the issue since it might contain sensitive information.


[Content Hidden]

I understand. Ben, Thank you so much for getting back at me.

Isn’t that the normal way of all multisite networks since it’s one single install for everything including plugin’s and themes … Only user content (Pages, text, images etc) is stored under their particular subsite folder.

My multisite setup is standard, doesnt have any special modification (only changed it from subdirectory to subdomain but thats only a domain setup), its actually a fresh install, and besides the plugin name I havent modified anythng on the actual plugin … I tried reinstalling the plugins as well … what else can we do? any troubleshoot guide ? any deeper support from you?

Hey Carlos,

I’m not really a multisite expert so I’m just basing this from a dev site we have on multisite. I’m pretty sure what we have is what I would consider standard since it is made for troubleshooting purposes. On our multisite install, the subsite is getting its data from /wp-content/uploads/sites/4/ with the number varying depending on which subsite.

We can check further if you could grant us temp admin access to the site. You can use the private reply option below. If you don’t mind throwing in FTP access as well that would be great. :slight_smile:


[Content Hidden]

Thank you!

Hey Carlos,

Would you mind sending in access to the WP admin as well? :slight_smile:



[Content Hidden]

Hey Carlos,

Sorry I never got to play around with the site during the weekend. Was gonna do so today but when I visited the site it seems to be loading the layout correctly so I would assume the problem has been fixed? Do you mind sharing what the solution was? :slight_smile:


Ben, its the strangest thing … I thought you had fixed it, it worked great this morning, but this afternoon it stopped working, its broken again which is scary going in business with this glitch. I turned off every plugin installed to see if it was a conflict with another plugin, right now “Beaver Builder” its the only plugin active and it still doesnt work … I will greatly appreciate it if you help me find what the problem is … thank you

I was able to identify a strange behavior, there is one plugin called “Ultra WordPress Admin” that is simple admin theme to make changes to the back end. When this plugin is active the Beaver Builder plugin works fine on subsites but when its inactive the Beaver plugin starts to malfunction. I installed it this weekend and thats why the issue seems to be fixed. I would expect a conflict but working the other way around. I am very concerned as I’m afraid this problem could cause major issues when I hace several websites relying on it, The beaver Builder must work fine on its own. Im not sure whats going on here but if you can find the issue I would greatly appreciate it!

Right now the plugin is working because I activated the other plugin

Hey Carlos,

We may need to play around with the site for a bit more. Is there anything we’re not allowed to do on these sites, e.g., deactivating a plugin network wide. Rather, are any of these sites live?


theres no live sites yet so feel free to deactivate plugins … I would specifically deactivate “Ultra WordPress Admin” so you can see BB builder plugin break, i think it needs to be fixed without any other plugin interfering, then make sure it still works when “Ultra WordPress Admin” is activated again … please let me know how can I make this easier, I understand that your time is very valuable.

Thanks Carlos! Is the account you set us up with a super admin account? It might be my unfamiliarity with the admin panel them you’re using, but I can’t access the network admin dashboard. Also, just to confirm, this issue happens with all other plugins disabled?

The account is in fact the super admin … theres no a link straight to network settings, just type and you’ll be there … you can disable all the plugins you want … the plugin that “fixes” the issue is the plugin that ads the admin colors and style, once you disable that the admin will look like the typical wordpress site but BB builder will start mal-funcioning …

Thanks Carlos. The link is working.

When the Ultra WordPress Admin plugin is enabled/disabled, the paths for assets changes. Here is the file path when the plugin is turned on:

and when it’s turned off:

I am not sure why this is happening, but I suspect this is where the problem stems from. Do you have any ideas why this might be happening? Is there any documentation or instructions available from Ultra WordPress Admin we could look at?

Also, did this problem start before you installed the UWA plugin? When did you notice it? Any ideas or clues you could provide would be helpful. Thanks!

I don’t know why the path is getting changed but I would expect BB builder to function well without the UWA plugin.

I just deactivated ALL plugins and completely DELETED the UWA plugin and the BB builder is broken again on subsites … it only works on main site.

I cannot rely on installing the other plugin to fix BB builder, again, I know your time is extremely valuable and I greatly appreciate it if you help me find what the problem is. Its a fresh installation, havent changed anything on the core of the wordpress files, only plugins. Please let me know

Carlos, thanks for deactivating everything!

I tried creating a new site (bbtest) and the theme styles aren’t loading. I haven’t touched the builder yet.

Ben mentioned this earlier:

Instead of looking for the files under /wp-content/uploads/, the subsite is looking for it under /files/ causing 404 errors for the layout JS and CSS files that BB needs to load the template.

This is still happening and it’s probably another clue. Do you know which plugin changed the directory structure? Maybe WordPress MU Domain Mapping?